New updates delayed by location service issues

02 Mar 2023 21:11 UTC

Some references are experiencing higher than normal rate of errors when generating new updates due to a query performance issue with an internal service supporting location enrichment. Our engineering team is actively working on the issue and will provide another update or resolution shortly.

Update: 2023-03-07

Our engineering teams have taken steps to alleviate the core issue across most supported carriers and are now working to ensure all references are reprocessed and updated in a timely manner. Overall deliverability rates are continuing to improve. Another update will be posted as soon as further information on full resolution is available.

Update: 2023-03-08

All issues with our internal locations service have been resolved and reference processing has returned to normal. We are continuing to monitor all supported carriers for any reminaing issues and will report any new incidents if they occur.

Degraded performance

Affected Systems: Container API