BNSF Connection Disruption

Incident Report for Vizion

Resolved

This incident has been resolved.
Posted Apr 08, 2025 - 07:17 PDT

Investigating

Connectivity to BNSF is degraded and our team is investigating the cause. We will update this incident as soon as more information is available.
Posted Apr 01, 2025 - 06:27 PDT
This incident affected: Rail Connections (BNSF).